ja vajadzīgais Mozilla spraudnis kļuvis par “vecu”

[lasi tālāk uz savu atbildību! un kaut ko dari tikai, ja esi pārliecināts, ka saproti ko dari!]

pēdējā laikā Firefox, Thunderbird versijas mainās biežāk kā to funkcionalitāte un gadās, ka kāds iemīļotais spraudnis tiek atzīts par nesavietojamu. bieži tā nav pilna taisnība, vienkārši šai .xpi failā ir norādītas savietojamības versijas: Min un Max un jūsu “jaunais” pārlūks vai e-pasta lasītājs ir lielāks par norādīto Max. tad nu ir trīs iespējas:

  • nelietot iemīļoto spraudni, sameklējot ko tā vietā vai gaidīt, kad autors pielabos savu darinājumu
  • atarhivēt .xpi un korektā veidā sarediģēt Max vērtību
  • atslēgt versiju pārbaudi

šoreiz par pēdējo, jo tā ir ātrākā, lai arī ne ļoti korektā iespēja …

sākumā jātiek pie konfigurācijas redaktora:

  • Firefox tas atradīsies, ja adresu laukā ierakstīsim “about:config”
  • Thunderbird tas atrodas Tools/Options/Advanced/General [Config Editor…]

tad ar peles labo taustiņu brīvā vietā un sakām, ka jāveido jauna vērtība, kuras tips ir ‘Boolean’, kura saucās ‘extensions.checkCompatibility.7.0’, kur 7.0 vietā jūsu programmas versija, jāizvēlas vērtība ‘False’. pārstartējam programmu un spraudnim atkal vajadzētu strādāt

[tomēr vēlreiz atgādinu – izdarītais, iespējams, rada savietojamības problēmas un palielina drošības riskus!]

Comments are closed.